We are continuing to investigate this issue. We have no estimated time as to when this issue will be resolved. All Synthaly projects have been set to private,
Posted May 27, 2025 - 05:37 UTC
Update
We are continuing to investigate this issue. We have no estimated time as to when this issue will be resolved. All Synthaly projects have been set to private,
Posted May 27, 2025 - 05:34 UTC
Investigating
We are currently investigating this issue.
Posted May 26, 2025 - 20:52 UTC
This incident affects: User (Website, Mobile App, Xbox App, Avatar), Player (Website, Mobile App, Xbox App, Games, Avatar), and Creator (Developers, Administrators, Partners).